دستورات تنظیمات روتر

دستورات تنظیمات روتر که باید بدانید

در این مطلب می خواهیم دستورات تنظیمات روتر که کاربردی می باشد را در سطح CCNA آموزش دهیم :

مسیریابی در Mode های مختلف

هدف

فرمان

وارد شدن به Privileged mode

enable

برگشتن به User mode از Privileged mode

disable

وارد شدن به Global Configuration Mode

configure terminal

خارج شدن از روتر

logout or exit or quit

صدا کردن فرمان قبلی

<up arrow or <Ctrl-P

صدا کردن فرمان بعدی

<down arrow or <Ctrl-N

متوقف کردن یک عملیات

Shift> +  <Ctrl> + ۶>

ریفرش خروجی صفحه نمایش

<Ctrl-R>

کامل کردن یک فرمان

TAB

 

تنظیمات روتر

هدف

فرمان

پسورد گذاشتن برای کنسول روتر

 

“این پسورد به صورت Clear-text در فایل config ذخیره می‌‌شود”

Router(config)#line con 0
Router(config-line)#login
Router(config-line)#password cisco

پسورد گذاشتن برای دسترسی از راه دور به روتر (Telnet)

 

“این پسورد به صورت Clear-text در فایل config ذخیره می‌‌شود”

Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login

از بین بردن timeout کنسول

Router(config)#line con 0
Router(config-line)#exec-timeout 0 0

گذاشتن پسورد برای ورود به محیط Privileged

 

“این پسورد به صورت Clear-text در فایل config ذخیره می‌‌شود”

Router(config)#enable password cisco

گذاشتن پسورد امن برای ورود به محیط Privileged

“این پسورد به صورت رمزشده در فایل config ذخیره می‌‌شود”

Router(config)#enable secret class

از پسوردهای clear-text محافظت می‌کند

Router(config)#service password-encryption

تغییر اسم روتر

Router(config)#hostname Router2

فعال کردن یک اینترفیس

Router2(config-if)#no shutdown

غیر فعال کردن یک اینترفیس

Router2(config-if)#shutdown

تعیین سرعت کلاک برای کابل‌های سریال

Router2(config-if)#clock rate 64000

 تعیین پهنای باند منطقی برای اینترفیس سریال

Router2(config-if)#bandwidth 64

آیپی دادن به یک اینترفیس

Router2(config-if)#ip address 10.1.1.1 255.255.255.0

 مسیر استاتیک نوشتن برای رنج آیپی ۱۷۲٫۱۶٫۱٫۰/۲۴

Router2(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1

فعال کردن RIP برای شبکه ۱۷۲٫۱۶٫۰٫۰

Router2(config)#router rip

Router2(config-router)#network 172.16.0.0

غیر فعال کردن RIP

Router2(config)#no router rip

فعال کردن EIGRP با AS 200 برای شبکه ۱۷۲٫۱۶٫۰٫۰

Router2(config)#router eigrp 200
Router2(config-router)#network 172.16.0.0

غیر فعال کردن EIGRP

Router2(config)#no router eigrp 200

فعال کردن OSPF با PID 123 و روی area 0 برای شبکه ۱۷۲٫۱۶٫۱۰٫۰/۱۶

Router2(config)#router ospf 123
Router2(config-router)#network 172.16.0.0 0.0.255.255 area 0

غیر فعال کردن OSPF

Router2(config)#no router opsf 123

غیر فعال کردن CDP برای کل روتر

Router2(config)#no cdp run

 فعال کردن CDP برای کل روتر

Router2(config)#cdp run

غیر فعال کردن CDP روی یک اینترفیس خاص

Router2(config-if)#no cdp enable

 

فرمان‌های Show

هدف

فرمان

نمایش اطلاعات ورژن دستگاه

show version

نمایش تنظیمات کنونی (DRAM)

show running-config

نمایش تنظیمات Startup یا همان NVRAM

show startup-config

نمایش فایل IOS و اندازه Flash

show flash

نمایش وضعیت‌های اینترفیس FastEthernet 0/0

show interface fa0/0

نمایش اجمالی تمام اینترفیس‌های روتر

show ip interfaces brief

نمایش مشخصات کابل سریال روی اینترفیس ۰/۰

show controllers s0/0

نمایش اجمالی دستگاه‌های متصل شده توسط پروتکل CDP

show cdp neighbor

نمایش پروتکل‌های مسیریابی اجرا شده روی روتر

show ip protocols

نمایش جدول مسیریابی روتر

show ip route

 نمایش access-list ها و تعداد match های صورت گرفته

show access-lists

 

تنظیمات مدیریتی

هدف

فرمان

ذخیره کردن تنظیمات کنونی از روی DRAM به NVRAM

copy running-config startup-config

ترکیب کردن تنظیمات NVRAM با DRAM

copy startup-config running-config

کپی تنظیمات کنونی (DRAM) روی یک سرور TFTP

copy runing-config tftp

 ترکیب کردن تنظیمات روی سرور TFTP با DRAM

copy tftp runing-config

بکاپ فایل IOS روی سرور TFTP

copy flash tftp

آپگرید سیستم عامل روتر از روی سرور TFTP

copy tftp flash

 

عیب‌یابی و اشکال‌زدایی

هدف

فرمان

فعال کردن Debug برای RIP یا OSPF

debug ip rip or debug ip ospf

فعال کردن اطلاعات Debug برای EIGRP به صورت خلاصه

debug ip igrp events

فعال کردن اطلاعات Debug برای EIGRP به صورت جزئی‌تر

debug ip eigrp transactions

فعال کردن Debug برای PAP و CHAP

debug ppp authentication

خاموش کردن تمامی Debug ها

no debug all

undebug all

موفق باشید.

همچنین از طریق لینک زیر می توانید در کانال تلگرام ما عضو شوید :)

دستورات تنظیمات روتر

نظرات